Subject: Private IP address?

From: Mareline Sheldon <[email-masked]>
Date: Fri, 8 Feb 2002 08:11:55 -0800 (PST)

Hi,
I have a doubt on the utility of the private IP
address range 172.16/16 to 172.31/16, 192.168.0/24 to
192.168.255/16 etc.

AFAIK, these IP addresses are given to the sys admins
to assign inside their AS and these must be not
advertised to the world outside. For communication
with the outside world we must use some well defined
unique IP address. 

Is that so?

This leads to a doubt .. 

If i have a switch with say, two routers in it having
private IP addresses assigned as 172.31.1.1 and
172.31.1.2. I can then not have these IP addresses
outside in my network. Right?

regards,
mareline s.

__________________________________________________
Do You Yahoo!?
Send FREE Valentine eCards with Yahoo! Greetings!
http://greetings.yahoo.com

---

From: TOMSON ERIC <[email-masked]>
Date: Tue, 12 Feb 2002 13:08:47 +0100

-----Original Message-----
From: Mareline Sheldon [mailto:[email-masked]]

Hi,

>> There is no doubt to have : they are private ranges, for private use. It means, you don't have to ask/warn anybody to use them in your private network. You can build your own private network with no direct connection to the public Internet (i.e. not being part of the Internet), and freely use those private ranges (one range per class - A, B, C).

Is that so?

>> Those addresses are simply not used/recognized/routed on the public Internet. You can do anything inside your private network, but not use them for any public interface. If you want your network to be connected to the Internet, you need at least a router or a network address translator between your private network and the public Internet.

This leads to a doubt .. 

>> Where is the problem? Any router has at least 2 interfaces. In this case, you have one interface connected to your private network and using one private address, and one other interface connected to the public Internet and using one public/official address. That's one of the purposes of a router, by the way.

regards,
mareline s.

>> If you need more information, any additional detail, we can exchange mails privately to avoid flooding this mail list with those basic topics. Don't hesitate.