Subject: RE: Any idea the ratio of end user workstations to network equipments

From: "Christian Huitema" <[email-masked]>
Date: Fri, 15 Feb 2002 08:35:29 -0800

Good places to start are:

IANA, INTERNET PROTOCOL V4 ADDRESS SPACE:
http://www.iana.org/assignments/ipv4-address-space

Internet Domain Survey:
http://www.isc.org/ds/

Telcordia's Netsizer, which includes breakout by domains:
http://www.netsizer.com/

BGP Routing table statistics:
http://www.apnic.net/stats/bgp/

I am not aware of any publication listing the ratio of networking
equipment to hosts. You will have to conduct some statistical sampling,
e.g. get a few friendly domains administrators to tell you their ratios
and extrapolate. I do not advise that you try the hacker's path, i.e.
pick address at random and use hackers' tools to remotely sense the type
of the equipment; it is bad practice, and your results would be tainted
by statistical errors due to firewall practices.

-- Christian Huitema

> -----Original Message-----
> From: Jian Bo Huang [mailto:[email-masked]]
> Sent: Friday, February 15, 2002 8:03 AM
> To: ietf
> Subject: Any idea the ratio of end user workstations to network
equipments
> Importance: High
> 
> Dear Sirs,
> 
> For my project needs, I want know some statistic data on the usage of
IP
> address. That means:
> 
> 1) How many addresses are occupied and how many are unassigned?
> 2) How many addresses are used for servers, routers and other network
> equipments, in contrast with the user end PCs or workstations? That is
> the ratio of end user workstations to network equipments.
> 
> I tried to find, but failed on no idea! Have you any suggestion?
> 
> Thank you!
> 
> Truly yours,
> Jian Bo Huang
> 
> MSc Student
> Department of Electronic Engineering,
> University of Surrey
> Guildford, Surrey
> GU2 7XH, UK
> Email: [email-masked]
> 	  Or [email-masked]
> Phone: +44-870-2820955

---

From: [email-masked]
Date: Fri, 15 Feb 2002 12:02:50 -0500

> by statistical errors due to firewall practices.

An even bigger danger, statistics-wise, is assuming that because it's
answering on ports 25, 80, 109, and 119, that it's a server, when it's
more likely just another desktop machine running WAAAY too many services
by default....

How many people do you think found out they had IIS installed when CodeRed
or Nimda pointed it out to them?  And how many do you think are *still*
unaware they have IIS on their desktop system? ;)

-- 
				Valdis Kletnieks
				Computer Systems Senior Engineer
				Virginia Tech