Subject: RE: Modems

From: TOMSON ERIC <[email-masked]>
Date: Mon, 17 Jun 2002 11:25:59 +0200

It IS the ISO OSI model. I see no contradiction with TCP/IP. Simply, there is no link layer in TCP/IP : it's a model that only provides higher layers and must be implemented over an existing link layer technology :

OSI
Layer  Name             TCP/IP
-----------------------------------
7      Application    ]
6      Presentation   ] APPLICATION (HTTP, FTP, DNS,...)
5      Session        ]
-----------------------------------
4      Transport        TRANSPORT (TCP, UDP)
-----------------------------------
3      Network          INTERNET (IP)
-----------------------------------
2      Data Link      ] Link layer
1      Physical       ] (PPP, Ethernet,...)

No model is supposed to obligatorily cover the 7 OSI layers. Look at NetWare, very close to TCP/IP : it only covers the 5 upper layers and doesn't provide the two first layers, neither.

Such models must be completed with "something" at those 2 lowest layers in case of a practical/full implementation : TCP/IP over Ethernet or over PPP, NetWare over Token Ring or over ISDN, etc. In other words, those models are "blind" to the lower layers : whatever those lower layers, they will transparently use ANY underlying technology and run above it.

On the other hand, there are models only covering the LOWEST layers, like LANs (IEEE 802 : 2 first layers), ATM (2 first layers), X.25 (3 first layers), etc. Whatever is implemented over them to run above them.

-----Original Message-----
From: Bill Cunningham [mailto:[email-masked]]

This looks like the ISO OSI model. I'm more familiar with TCP/IP.

----- Original Message -----
From: "Michel Py" <[email-masked]>

> Frame is the PDU name for layer 2.
>
> Layer  Name          PDU
> 7      Application   message
> 6      Presentation  message
> 5      Session       message
> 4      Transport     Segment
> 3      Network       Packet/Datagram
> 2      Data Link     Frame
> 1      Physical      Bit
>
> Michel.

---

From: "Stephen Sprunk" <[email-masked]>
Date: Mon, 17 Jun 2002 19:04:28 -0500

Thus spake "TOMSON ERIC" <[email-masked]>
> It IS the ISO OSI model. I see no contradiction with TCP/IP. Simply, there is
no link layer in TCP/IP : it's a model that only provides higher layers and must
> Layer  Name             TCP/IP

I'd always considered TCP/UDP to cover both layers 4 and 5, and ASCII/EBCDIC/XDR
to cover layer 6.

S