Subject: ISO 3166 mandatory?

From: lconroy <[email-masked]>
Date: Wed, 20 Feb 2008 17:23:52 +0000

Hi Folks,
  WTF - why am I REQUIRED to enter the ISO-3166 code for my country  
of residence.
This is the ->Internet<- Engineering Task Force. So what the heck is  
wrong with UK
(as in the country code TLD of the same name), not to mention the  
Country.

This is (if nothing else) a Fenian ploy.

I am VERY unamused with this. If you must insist on this drop down  
list, then add
United Kingdom (UK), you *&$£@%s!

Why did this HAVE to change?

all the best,
   Lawrence

_______________________________________________
Ietf mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ietf

---

From: "Daniel Brown" <[email-masked]>
Date: Wed, 20 Feb 2008 12:31:20 -0500

>   WTF - why am I REQUIRED to enter the ISO-3166 code for my country
[snip!]
> This is (if nothing else) a Fenian ploy.
[snip!]
> add United Kingdom (UK), you *&$£@%s!

    Not sure where in your rant you mentioned where this occurs.  I
must've missed it.  In any case, some enjoyable literature pertinent
to your inquiry:

(Citing http://www.ietf.org/maillist-new2.html)

Inappropriate Postings to Discussion Lists

Inappropriate postings to discussion lists include:

    * Unsolicited bulk e-mail
    * Discussion of subjects unrelated to IETF policy, meetings,
activities, or technical concerns
    * Unprofessional commentary, regardless of the general subject

-- 
</Dan>

Daniel P. Brown
Senior Unix Geek
<? while(1) { $me = $mind--; sleep(86400); } ?>
_______________________________________________
Ietf mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ietf

---

From: lconroy <[email-masked]>
Date: Wed, 20 Feb 2008 17:39:15 +0000

Hi folk,
  I guess that the IETF Meeting Registration pages are run by/on  
behalf of the IETF, and that's where the mandatory code is required.
Also, could someone fix the python - it appears to barf now that the  
Social is sold out.
[who apparently got the last ticket, but whose colleague now can't  
register as the form comes up with a python error]

all the best,
   Lawrence

---

From: John C Klensin <[email-masked]>
Date: Wed, 20 Feb 2008 12:50:10 -0500

Don't worry.  This problem effectively no longer occurs.  It has
been replaced by the following "feature":

(1) The Social event line, which we were never required to fill
in before, especially with a specific number of tickets, in
order to register for IETF, now reads "sold out".

(2) When one tries to submit the registration form, one gets a
rather nasty Python error that seems to be associated with
trying to convert "sold out" to a numeric value to calculate a
charge.

IAOC members: Since the transition, we've had

	* Several different examples of the I-D submission tool
	not accepting valid I-Ds (fixed serially)
	
	* The I-D submission tool declining to accept I-Ds
	because no one managed to correct it to reflect the
	actual deadline.
	
	* The introduction of indicating whether or not one
	wanted to attend the social and how many tickets were
	wanted as a condition of registration.
	
	* The certificate problems mentioned in another note.
	
	* This ISO 3166 code business, rather than, e.g., a
	country name.

While I'm generally very sympathetic and tolerant of transition
difficulties, there comes a point in which this looks like
systematic under-commitment of resources to testing and quality
control --or adoption of the industry practice of "put it out
there and let the users do the testing"-- a behavior that is
sometimes associated with "low bid" decisions.   

How much more of this will it take before you conclude that we
have a problem?

     john

--On Wednesday, 20 February, 2008 17:23 +0000 lconroy
<[email-masked]> wrote:

> Hi Folks,
>   WTF - why am I REQUIRED to enter the ISO-3166 code for my
> country   of residence.
> This is the ->Internet<- Engineering Task Force. So what the
> heck is   wrong with UK
> (as in the country code TLD of the same name), not to mention
> the   Country.
>...

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 20 Feb 2008 10:16:26 -0800

Hi -

> From: "lconroy" <[email-masked]>
> To: "IETF discussion list" <[email-masked]>
> Sent: Wednesday, February 20, 2008 9:23 AM
> Subject: ISO 3166 mandatory?
...
> why am I REQUIRED to enter the ISO-3166 code for my country  
> of residence.
...

Quite right.  It should use UN M.49 codes instead.
;-)

Randy

---

From: "Frank Ellermann" <[email-masked]>
Date: Wed, 20 Feb 2008 19:25:17 +0100

> behalf of the IETF, and that's where the mandatory code is required.

Tons of forms want this for obscure purposes, if in doubt I pick UM.

The history of UK vs. GB is explained in RFC 3071 - for unrelated
reasons I read it yesterday again.  Obviously one country should
have one code, and as far as that that code is mnemonic it should
depend on the name of the country.  In theory "united kingdom" can
be less persistent - in various countries that's not only a theory.

 Frank

---

From: Tony Finch <[email-masked]>
Date: Wed, 20 Feb 2008 19:27:30 +0000

On Wed, 20 Feb 2008, Frank Ellermann wrote:
> reasons I read it yesterday again.

RFC 3071's comments about the crown dependencies are now obsolete,
since they have been added to ISO 3166. The ISO 3166 FAQ also has
more information about UK vs. GB than RFC 3071:
http://www.iso.org/iso/country_codes/iso_3166-faqs/iso_3166_faqs_specific.htm

See also the international conventions on road traffic, under which the
international licence plate country codes are maintained by the UN. GB has
been the designation for the United Kingdom for a long time, from before
the existance of ISO 3166 let alone the DNS.
http://en.wikipedia.org/wiki/List_of_international_license_plate_codes

Tony.
-- 
f.a.n.finch  <[email-masked]>  http://dotat.at/
SHANNON: SOUTHWEST 5 TO 7, OCCASIONALLY GALE 8. MODERATE OR ROUGH, INCREASING
VERY ROUGH IN NORTH. OCCASIONAL RAIN. MODERATE OR GOOD, OCCASIONALLY POOR.
_______________________________________________
IETF mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ietf

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 20 Feb 2008 21:26:14 +0100

On Wed, Feb 20, 2008 at 05:23:52PM +0000,
 lconroy <[email-masked]> wrote 
 a message of 23 lines which said:

> So what the heck is wrong with UK (as in the country code TLD of the
> same name),

It's true that there is a discrepancy between ISO 3166 and the root of
the DNS. Do not worry, David Conrad, IANA, reads this list and he will
certainly resolve the discrepancy today by renaming the TLD ".uk" to
".gb".

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 20 Feb 2008 21:49:43 +0100

On Wed, Feb 20, 2008 at 12:50:10PM -0500,
 John C Klensin <[email-masked]> wrote 

> 	* This ISO 3166 code business, rather than, e.g., a

While a country name is more intuitive and certainly better for a
general Web site, it seems safe to assume that IETF members are a bit
more used to standards than the general population and that ergonomics
of this field may not be the most important thing to discuss?

A partial list of standards track RFC referencing ISO 3166:

4933
4776
4646
4524
4517
3982
...

---

From: Bill Manning <[email-masked]>
Date: Wed, 20 Feb 2008 13:19:41 -0800

> Tons of forms want this for obscure purposes, if in doubt I pick UM.

	UM... glad to have you aboard...  www.nic.um  :)

> be less persistent - in various countries that's not only a theory.

	actually, there were other issues w/ the use of
	country codes & the IETF in recent memory. A -MUCH-
	more sensitive approach is to call these entities 
	"economies"  :)

--bill

--bill
Opinions expressed may not even be mine by the time you read them, and
certainly don't reflect those of any other entity (legal or otherwise).

---

From: Dave Cridland <[email-masked]>
Date: Wed, 20 Feb 2008 22:12:55 +0000

On Wed Feb 20 20:26:14 2008, Stephane Bortzmeyer wrote:
>  lconroy <[email-masked]> wrote  a message of 23 lines  
> which said:
> 

In case anyone hasn't understood why the choice of GB as a  
country-code for the UK is somewhat contentious to some people, it's  
that "Great Britain" is [the island containing] Scotland, England,  
and Wales, whereas the country itself is called "The United Kingdom  
of Great Britain and Northern Ireland".

Whilst I follow the decision of avoiding "United" and "Kingdom"  
within country-codes, the resulting choice is unfortunate for people  
on either side of Northern Irish politics, since GB either excludes  
Northern Ireland, or else implicitly convolves it with the rest of  
the UK, depending on one's viewpoint.

Whilst that's not a debate I take sides in, to many people this is an  
important and sensitive issue. The solution is usually to hide  
country codes from the user (using country names instead), or allow  
UK and translate it internally.

Personally, I just use AQ for marketing forms, and often wonder how  
they handle that.

Dave.
-- 
Dave Cridland - mailto:[email-masked] - xmpp:[email-masked]
  - acap://acap.dave.cridland.net/byowner/user/dwd/bookmarks/
  - http://dave.cridland.net/
Infotrope Polymer - ACAP, IMAP, ESMTP, and Lemonade
_______________________________________________
IETF mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ietf

---

From: David Conrad <[email-masked]>
Date: Wed, 20 Feb 2008 14:15:55 -0800

Hi,

ISO 3166 MA has designated "UK" as "exceptionally reserved".  IANA has  
permitted the use of codes ISO designates as "exceptionally reserved"  
in ISO-3166 for quite some time (the yellow boxes in the table at http://www.iso.org/iso/iso-3166-1_decoding_table) 
.

Oh, and I'm not with IANA anymore and even if I was, we couldn't  
really do anything to ccTLDs without them requesting it (but you know  
that)...

Regards,
-drc

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Thu, 21 Feb 2008 00:25:54 +0100

> certainly resolve the discrepancy today by renaming the TLD ".uk" to

Don't joke about that. A few years ago I did some statistics on the  
numbers of IPv4 addresses given out and I wrote this:

http://bgpexpert.com/addrspace2005.php

"In the list at the bottom of this page, there are numbers for both  
"UK" and "GB". This is because the RIPE NCC uses the two letter code  
"UK" for address space given out to entities in the UK. However, some  
address space in the UK was given out by other registries, which use  
the official country code for the United Kingdom of Great Britain and  
Northern Ireland, which is "GB".
UPDATE feb 1

The total for 2005 is now 167.54 million addresses, and the RIPE NCC  
has decided to use the official country code "GB" rather than the  
commonly used code "UK" in its statistics from now on."

Not sure if RIPE still accepts "UK" but they now have "GB" in the RIPE  
database. I'm not sure if the inhabitants of GB who deal with RIPE  
found this amusing.
_______________________________________________
IETF mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ietf

---

From: "Frank Ellermann" <[email-masked]>
Date: Thu, 21 Feb 2008 01:05:50 +0100

Tony Finch wrote:

> RFC 3071's comments about the crown dependencies are now obsolete

Yes, Debbie fixed this.  Unfortunately IANA introduced EU as a new
exception.  

Stephane Bortzmeyer wrote:

> Do not worry, David Conrad, IANA, reads this list and he will
> certainly resolve the discrepancy today by renaming the TLD 
> ".uk" to ".gb".

LOL, is that something they should do with DNAME ?  <g>

David Conrad wrote:

> IANA has permitted the use of codes ISO designates as 
> "exceptionally reserved" in ISO-3166 for quite some time 

IANA forgot to update RFC 1591, and ICANN forgot to update
IDP-1, or are you talking about something else ?

> UM... glad to have you aboard...  www.nic.um  :)

Carribean faction, please ;-)  Some years ago I had the fun
to reorganize directory categories based on the US codes into
ISO codes, and Navassa tended to spoil the result.

> A -MUCH- more sensitive approach is to call these entities 
> "economies"  :)

For that approach the UN codes might be better, if an ugly
hole near China is no problem for you.

 Frank

---

From: David Conrad <[email-masked]>
Date: Wed, 20 Feb 2008 16:30:15 -0800

Frank,

On Feb 20, 2008, at 4:05 PM, Frank Ellermann wrote:
> Unfortunately IANA introduced EU as a new exception.

ICANN introduced the top-level domain for EU by request of appropriate  
entities within the EU.

> IDP-1, or are you talking about something else ?

Neither of those documents needs to be updated since IANA and ICANN  
are still using ISO-3166.  If you look on the table at the URL I  
provided for decoding ISO-3166-1, you'll see "exceptionally reserved"  
means "Code element may be used but restrictions may apply".  None of  
the restrictions on those codes have been violated by their use as TLDs.

Regards,
-drc

---

From: "Frank Ellermann" <[email-masked]>
Date: Thu, 21 Feb 2008 02:24:51 +0100

> ICANN introduced the top-level domain for EU by request
> of appropriate entities within the EU.

Yes, one of the "exceptionally reserved" codes, added to
the AC + UK club of exceptions.  That's 5+1-3 exceptions
in comparison with the list in RFC 3071 (published 2001).

 
> Neither of those documents needs to be updated since IANA
> and ICANN are still using ISO-3166.

When I ask whois.iana.org for CP, DG, EA, FX, IC, or TA it
tells me that there's no such TLD.  And the three remaining
"exceptionally reserved" codes are AC, EU, and UK.

> If you look on the table at the URL I provided for decoding
> ISO-3166-1

Thanks, I publish links to English and French versions of the
table for six years on <http://purl.net/xyzzy/bookmark.htm>.

I need it for <http://purl.net/xyzzy/src/rxwhois.cmd> with a
list of anything that remotely could be a TLD down to cases
like LOCAL, NATO, FIRM, ARTS, RB, RC, etc.  Stopping short 
before the lala lands of "alternate roots" or the WIPO codes
(the violet codes in the table).

> "exceptionally reserved" means "Code element may be used but
> restrictions may apply".  None of the restrictions on those
> codes have been violated by their use as TLDs.

| The IANA is not in the business of deciding what is and what
| is not a country.  The selection of the ISO 3166 list as a
| basis for country code top-level domain names was made with
| the knowledge that ISO has a procedure for determining which
| entities should be and should not be on that list.

"That list" is not yellow or violet or red or blue fields in
the table, it is the green fields.  With grey as colour for
former green fields, TP is a whois.iana.org example for grey.

It took an IETF WG about a year to brain wash me until I got
it, when they changed their mind allowing yellow excluding UK
I unsubscribed.

 Frank

---

From: David Conrad <[email-masked]>
Date: Wed, 20 Feb 2008 18:09:14 -0800

Frank,

On Feb 20, 2008, at 5:24 PM, Frank Ellermann wrote:
> tells me that there's no such TLD.

Well, yes.  They haven't been delegated yet.  Ah, I see the  
discrepancy.  When you do a query against EH (for example) you get a  
blank template but when you query against (say) FX, you get not  
found.  Not sure why this is the case as it is clearly broken.  I'll  
recommend it get fixed.

> former green fields, TP is a whois.iana.org example for grey.

My understanding is "that list" was chosen for the "usable" codes.   
"Exceptionally reserved" are usable with restrictions and using them  
as TLDs doesn't appear to violate the restrictions.  Not sure I see  
what the problem is.

Regards,
-drc

---

From: "Frank Ellermann" <[email-masked]>
Date: Thu, 21 Feb 2008 03:57:02 +0100

David Conrad wrote:

 [CP, DG, EA, FX, IC, or TA]
> When you do a query against EH (for example) you get a blank
> template but when you query against (say) FX, you get not 
> found.  Not sure why this is the case as it is clearly broken.
> I'll recommend it get fixed.

They could make it worse if they add the "fantasy island codes".

Let the relevant experts like Debbie or Stéphane decide if they
want more or less obscure territories listed as country or not,
the job of the governments, the UN, and the ISO 3166/MA.  Not
a job for a whois.iana.org admin, who might not know what it is:

TA is reserved by the UPU, as long as IANA does not want to get
into the business of selling stamps or similar they do not need
it.  TA belongs to SH, SH belongs to GB => let Debbie handle it,
not IANA, this worked like a charme for GG + IM + JE in 2006.

EA, unless IANA intends to get in the business of sponsoring a
war between Morocco and the EU they should stay away from EA.
Let the government of Spain decide if they want a country code.  

Similar IC, Spain is notoriously picky about such issues, e.g.,
they will not recognize Kosovo as indepenent country, it could
be a bad example for Basque.  IANA has no business to sponsor
civil wars in parts of Europe - of course now folks in Africa
could ask what I'm smoking, as IC clearly is a part of Africa.

DG is covered by IO, nobody needs it.  But it was the place of
some nasty near genocide, and IANA should not touch it without
prior consultations with both the UK and the US governments.

That is *one* meaning of the RFC 1591 and IDP-1 country rules,
unless I seriously missed their drift.  There are authorities
deciding what is and what is not a country, and IANA isn't one
of these authorities.

> Not sure I see what the problem is.

For the "fanatsy island codes" see above.  For EU it's just a
silly idea that everybody in the EU could have two codes, the
GB + UK mess is bad enough.  With ASIA and CAT, why didn't
they get say EURO ?  Why do they always need an extra-rule ?
Why can't they have a decent whois server like most gTLDs ?

 Frank

---

From: John C Klensin <[email-masked]>
Date: Thu, 21 Feb 2008 00:31:12 -0500

--On Wednesday, 20 February, 2008 16:30 -0800 David Conrad
<[email-masked]> wrote:

> ICANN introduced the top-level domain for EU by request of
> appropriate   entities within the EU.
> 
> Neither of those documents needs to be updated since IANA and
> ICANN   are still using ISO-3166.  If you look on the table at
> the URL I   provided for decoding ISO-3166-1, you'll see

David,

FWIW, this is a fairly radical re-interpretation of the policies
IANA followed under RFC 1591 and even of any policy I'm aware of
the ICANN Board having approved.  You will also note that
particular --and very liberal-- interpretation of the meaning of
"exceptionally reserved" is of fairly recent origin.

This may, of course, not have anything to do with anything of
importance (rather than of theoretical interest only), but I
have a bias against both misunderstandings of history and
rewriting history to suit more contemporary convenience.

     john

---

From: David Conrad <[email-masked]>
Date: Wed, 20 Feb 2008 21:56:38 -0800

Frank,

> They could make it worse if they add the "fantasy island codes".

They who?  I doubt ISO-3166 MA will be adding "fantasy island codes",  
but if they do, IANA is not in a position to deny the creation of TLDs  
representing those codes.  IANA doesn't make the codes and takes no  
position on whether they should exist or not.  All IANA staff does is  
check to see if the code is in the ISO-3166-1 list (including  
"exceptionally reserved" codes, for good or ill -- again, not an IANA  
decision) and if it is and the delegation of the TLD is appropriate,  
the request is processed.

> a job for a whois.iana.org admin, who might not know what it is:

??

We seem to be talking past each other.  IANA would obviously not  
create delegations for those code elements unless duly authorized  
requesters from the territories those codes designate requested it.  I  
was merely indicating the IANA database should be consistent for  
ISO-3166 codes that are not delegated.

If you don't think a code should exist, take it up with ISO-3166 MA.

Regards,
-drc

---

From: David Conrad <[email-masked]>
Date: Wed, 20 Feb 2008 22:02:24 -0800

John,

On Feb 20, 2008, at 9:31 PM, John C Klensin wrote:
> the ICANN Board having approved.

Given ICANN's board approved the EU delegation and AC and UK were  
delegated some time back, it would seem there is some room for  
argument on this point.

> rewriting history to suit more contemporary convenience.

I am not speaking of history and yes I am aware of much of it.  I am  
speaking of current policy.  If you feel that policy is in error,  
please raise it with the ccNSO.  IANA only does what it is told.  But  
you know this.

Regards,
-drc

---

From: "Frank Ellermann" <[email-masked]>
Date: Thu, 21 Feb 2008 09:22:46 +0100

> If you don't think a code should exist, take it up with ISO-3166 MA.

The IAB will do if an RFC tries the stunt to use "exceptionally
reserved" codes as country codes.  And if the "ccSNO" obsoleted
RFC 1591 and IDP-1 they failed to inform the Internet at large:
<http://forum.icann.org/lists/idn-cctld-fast-track/msg00001.html>

 Frank

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 20 Feb 2008 22:52:44 +0000

>How much more of this will it take before you conclude that we
John,
I haven't been with IETF long enough to witness any earlier secretariat 
transitions (if such thing ever happened before). So it is hard for me 
to compare. But I don't think for an organization of our size with 
different web site access patterns it would have been possible to 
predict all transition problems. I think we should give secretariat some 
time, say till Dublin IETF, to sort things out.

Regards,
Alexey

P.S. I am surely hoping that IETF doesn't have to go through another 
transition in 2 years.

---

From: Tony Finch <[email-masked]>
Date: Thu, 21 Feb 2008 17:34:25 +0000

> LOL, is that something they should do with DNAME ?  <g>

I always preferred hmg.gb to gov.uk.

Tony.
-- 
f.a.n.finch  <[email-masked]>  http://dotat.at/
VIKING NORTH UTSIRE SOUTH UTSIRE: SOUTHWEST 7 TO SEVERE GALE 9, OCCASIONALLY
STORM 10 IN VIKING. ROUGH OR VERY ROUGH, INCREASING VERY ROUGH OR HIGH. RAIN
OR SQUALLY SHOWERS. MODERATE OR POOR.
_______________________________________________
IETF mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ietf