Subject: Re: transitioning email rules

From: Paul Hoffman <[email-masked]>
Date: Tue, 5 Feb 2008 14:06:24 -0800

At 8:35 AM +0200 2/5/08, Yaakov Stein wrote:
>Would it be possible to post information that would help here ?
>What is constant and can be relied upon ?

The List-ID: mail header, RFC 2919. It should hopefully be on every 
IETF mailing list, and should remain relatively* constant.

*Some changed during this last transition, but in a way that should 
be stable for many years to come.

--Paul Hoffman, Director
--VPN Consortium
_______________________________________________
Ietf mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ietf

---

From: Benno Overeinder <[email-masked]>
Date: Tue, 05 Feb 2008 23:09:34 +0100

> What is constant and can be relied upon ?

The List-Id works pretty well for me, for example this IETF discussion, 
announce, and ID announce mailing lists are filtered by procmail using:

:0:
* ^List-Id: IETF-Discussion <ietf.ietf.org>
Mail/ietf

:0:
* ^List-Id: <ietf-announce.ietf.org>
Mail/ietf-announce

:0:
* ^List-Id: <i-d-announce.ietf.org>
Mail/i-d-announce

Best,

-- Benno

---

From: "Frank Ellermann" <[email-masked]>
Date: Tue, 5 Feb 2008 23:42:04 +0100

> What is constant and can be relied upon ?

List-Id is designed to be constant and reliable.
Two examples (this list and apps.discuss):

List-Id: IETF-Discussion <ietf.ietf.org>
List-Id: general discussion of application-layer protocols <discuss.ietf.org>

 Frank

---

From: James Galvin <[email-masked]>
Date: Tue, 05 Feb 2008 18:29:18 -0500

I can answer a few questions that will help.

AMS installed the default configuration of mailman and then 
imported each mailing list's individual configuration file as 
provided by NSS.

It should be the case now that all IETF hosted mailing lists are in 
the domain "ietf.org".  The mail server will be "mail.ietf.org".

However, there are some inconsistencies between lists.  For 
example, Mailman allows a list to set its domain.  Lists have been 
found to be in lists.ietf.org, optimus.ietf.org, megatron.ietf.org, 
and a few others.  Mailman allows other options that can be set on 
a per list basis that may also create inconsistencies between lists.

All the names that have been found are recognized and accepted by 
the mail server, but fixing the various list configurations will 
take time.  It is pretty low on the priority list right now because 
email is working.  There are other things that are not working and 
they are taking priority.

You can help by notifying "[email-masked]" when you find 
inconsistencies.  If you do this AMS can track them and they will 
get fixed in time.

Jim

-- On Tuesday, February 05, 2008 8:35 AM +0200 Yaakov Stein 
<[email-masked]> wrote regarding transitioning email rules --

>
> I assume that others have come across this problem as well,
> but I haven't seen anything mentioned about it on this list or
> the IETF sites.
>
> I receive over 500 non-spam emails every day (peaks can reach
> 1000).
> These include emails from about 15 IETF lists,
> about 25 other standardization lists, some 20 lists on technical
> topics,
> multiple internal corporate lists, (and even a few emails sent
> only to me).
>
> The only way I can deal with this load and maintain my sanity
> is by using a large set of sorting rules.
> I have quite a few rules dealing with IETF emails that all worked
> well until the transition.
>
> Some of my rules look for [WG-NAME] in the subject line.
>
> However, some WG lists (e.g. L2VPN) do not use this convention .
> Also, I sometimes have trouble when I forward an email to someone
> "for information"
> who then returns an urgent answer leaving the subject line
> intact.
>
> Some of my rules WERE based on the sender,
> for example, mails from [email-masked].
> With the transition the sender changed to
> [email-masked].
>
> I exchanged emails with [email-masked] and was told that
> this
> kind of change was here to stay. Being somewhat skeptical I
> decided to change
> the logic and to focus on the list to which it was sent, rather
> than the sender.
> I had avoided this in the past, since frequently people email
> someone else
> and only cc the list, making the logic more intricate.
>
> These new rules work some of the time, but not always.
> For example, in the past emails to the MPLS WG list
> (that were from [email-masked] but now come from
> [email-masked])
> were sent to [email-masked] . I modified my rule to flag
> this list address.
> But now the emails are being directed to [email-masked] !
>
> Would it be possible to set up guidelines for WGs to follow,
> including those (e.g. NTP) who use non-IETF domains ?
>
> Y(J)S
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 06 Feb 2008 00:29:03 +0100

Hi,

On 2008-02-05 07:35 Yaakov Stein said the following:
> but I haven't seen anything mentioned about it on this list or the IETF
> sites.
>  
> I receive over 500 non-spam emails every day (peaks can reach 1000).
> about 25 other standardization lists, some 20 lists on technical topics,
> 
> multiple internal corporate lists, (and even a few emails sent only to
> me).
>  
> I have quite a few rules dealing with IETF emails that all worked well
> until the transition.
...

I've found over the last ~5 years that the most consistent header on which
to sort is the X-BeenThere: header, which always reflect the list address,
without any other arbitrary junk around it (which unfortunately isn't true
for the the List-ID: header, which has text which may arbitrarily be modified
by a well-intentioned human, making it in practical experience a bit
unpredictable for sorting purposes).

So far, all of my IETF-related MUA sorting rules, which use X-BeenThere:,
have continued to function perfectly across the transition.

	Henrik