Subject: Re: Last Call: draft-klensin-rfc2821bis (Simple Mail Transfer Protocol) to Draft Standard

From: Pekka Savola <[email-masked]>
Date: Thu, 28 Feb 2008 08:10:41 +0200 (EET)

On Wed, 27 Feb 2008, The IESG wrote:
> The file can be obtained via
> http://www.ietf.org/internet-drafts/draft-klensin-rfc2821bis-08.txt
>
> Implementation Report can be accessed at
> http://www.ietf.org/IESG/implementation.html

I don't see the implementation report there.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
_______________________________________________
IETF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: "Frank Ellermann" <[email-masked]>
Date: Thu, 28 Feb 2008 12:53:44 +0100

The IESG wrote:

> <draft-klensin-rfc2821bis-08.txt> as a Draft Standard

In section 4.1.3 <dcontent> is undefined, fix proposed
in <http://article.gmane.org/gmane.ietf.smtp/6622>

<Standardized-tag> got no valid syntax, proposed fixes
in the same article.

For an <IPv6-addr> importing or adapting <IPv6address>
from STD 66 would be clearer:  The STD 66 syntax works
as is, without any additional restrictions in comments.

In section 4.2 <text> is undefined, it is unrelated to
the <text> in 2822upd.  Proposed fix, add a definition:

 text = 1*(%d32-126)

In section 4.2.2 (reply codes by function group) 251 and
551 should form one group.  STD 10 has a simple working
philosophy about 251+551, unfortunately broken by STD 3.

In section 4.1.2 <Keyword> and <Argument> are apparently
unused and can be removed.  For the collected syntax see
<http://hmdmhdfmhdjmzdtjmzdtzktdkztdjz.googlepages.com/2821bis.ABNF.1> 

The  ehlo-greet = 1*(%d0-9 / %d11-12 / %d14-127)  allows
NUL and obs-NO-WS-CTL, maybe this is a fair warning for
SMTP clients that servers can be peculiar. 

On the SMTP list Mark E. Mallet yesterday (too late for
2821bis-08) proposed a few clarifications.  About four of
his points could be errata if they'd make it in 2821bis.  

 Frank